开启辅助访问

QQ登录

只需一步,快速开始

注册 找回密码 切换到宽版 |

迅维网

查看: 334|回复: 19
[求助中]

苹果笔记本MacBook Pro A1278板号820-2879-B有待机牙刷头灯亮但不开机也不充电怎么修

[复制链接]
发表于 2018-11-29 18:38 | 显示全部楼层 |阅读模式

马上注册,阅读更多精彩内容

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 5605245 于 2018-12-1 14:38 编辑

接到一台苹果笔记本说不开机,按开关没有反应。拆机壳 插适配器上去 绿灯亮,待机电压3.3V ,PPVBAT_G3H_CHGR_REG 有12.5v。就是电池接口的正极只有0.15V 电压。 刷牙头有16.5V电压,中间针有2.83V ,电池接口的4 6脚总线电压有3.3V。 拨开适配器,电池电压也只有1.55V左右。是电池坏了吗?还是适配器的问题 手上没有其他适配器。用了一个14.5V的原装适配器 插上时  PPVBAT_G3H_CHGR_REG 有8.5-6v跳变,电池正极电压也跟着有8.5-6v跳变,过一阵后 也自动变为0.15V了 而 PPVBAT_G3H_CHGR_REG 变回稳定的12.5v。关键问题是。不开机呢,如果电池没有电了 应该也开机的吧?难道这款电池坏了也不开机!?大家帮分析分析.
到这里 我有一个问题想问大家。这个型号机器 如果不装电池,插上适配器后是不是公共点电压12.5V一会也就没有了。
今天我详细量充电IC 6259A 结果如下:(这些数据是接上电池,F7040保险两端即公共点电压为12.5V 而电池接口正极为0.15V是测试的,因为刚插入适配器时 公共点电压变化的,会有8V-6V 然后慢慢下降为0.15V的情况。变化时,电池接口正极有充电电压,但也跟着变化。然后连续拨多插几次适配器后,公共点12.5V电压不变,而充电电压一直为0.15V,而整个过程,适配器电压始终为16.8V,中间针始终为2.83V)
2脚DCIN 16.3V,
3脚ACin有3.9V,
10 11J脚系统总线时钟电压有3.3V,
13脚是总线复位有3.3V,
14脚是ACOK 有3.3V。17 18脚外围电阻那个通病问题 我测试了也没发现异常  2.2欧姆测试显示3欧姆。0欧姆电阻也正常0欧姆!
19 20有5.05V ,
25脚自举电压有16.8V,
现在疑问是26脚是16V。装不装电池测试26脚电压都为16V,
用14.5V的适配器时为14.5V 说明适配器电流小于0.15A!
苹果笔记本充电IC ISL6259A定义.jpg

800.jpg
803.jpg

804.jpg

805.jpg

806.jpg








801.jpg

本文由 5605245 原创或被授权转载制作,其他机构或个人未经许可严禁转载。
发表于 2018-11-29 18:45 来自手机 | 显示全部楼层
人为上拉batlow,不接电池可以开机

点评

这个点找到,但线路在板间的,直接上拉822电阻后 依然是低电平,不够强行拉高,怕出现其他问题。  详情 回复 发表于 2018-11-30 08:51
回复 支持 反对

使用道具 举报

发表于 2018-11-29 23:17 | 显示全部楼层
手上有一台这个机子电池鼓包了适配器可以开机!

回复 支持 反对

使用道具 举报

发表于 2018-11-30 00:19 | 显示全部楼层
量下各个电压有没有短路

点评

暂时没发现有短路现象。有一个情况就是有一根排线断了。接到指示灯的那挑排线断了,但不应该影响开机吧?  详情 回复 发表于 2018-11-30 08:56
拆机发现硬盘接口背面的供电电感烧,有阻值34欧。但不知道是不是原故障就只有,还是上家修后才出现的。这是二修机。  详情 回复 发表于 2018-11-30 08:54
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-11-30 08:51 | 显示全部楼层
152916623 发表于 2018-11-29 18:45
人为上拉batlow,不接电池可以开机

这个点找到,但线路在板间的,直接上拉822电阻后 依然是低电平,不够强行拉高,怕出现其他问题。

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-11-30 08:54 | 显示全部楼层
ros5229 发表于 2018-11-30 00:19
量下各个电压有没有短路

拆机发现硬盘接口背面的供电电感烧,有阻值34欧。但不知道是不是原故障就只有,还是上家修后才出现的。这是二修机。

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-11-30 08:56 | 显示全部楼层
ros5229 发表于 2018-11-30 00:19
量下各个电压有没有短路

暂时没发现有短路现象。有一个情况就是有一根排线断了。接到指示灯的那挑排线断了,但不应该影响开机吧?

回复 支持 反对

使用道具 举报

发表于 2018-11-30 20:39 | 显示全部楼层
我觉得问题出在 2.8V 这个信号  电压有些低,楼主沿着这个方向 查下去,肯定有收获。

回复 支持 反对

使用道具 举报

发表于 2018-11-30 20:40 | 显示全部楼层
比如查下 6259 的13脚   看看电压是否正常, 再看看SMC ,应该好修的

点评

2脚DCIN 16.3V,3脚ACin有3.3V,10 11J脚系统总线时钟电压有3.3V,13脚是总线复位有3.3V,14脚是ACOK 有3.3V。19 20有5.05V 25脚自举电压有16.8V,现在疑问是26脚是16V。装不装电池测试26脚电压都为16V,用14.5V的适配  详情 回复 发表于 2018-11-30 22:00
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-11-30 22:00 | 显示全部楼层
可乐炖香烟 发表于 2018-11-30 20:40
比如查下 6259 的13脚   看看电压是否正常, 再看看SMC ,应该好修的

2脚DCIN 16.3V,3脚ACin有3.3V,10 11J脚系统总线时钟电压有3.3V,13脚是总线复位有3.3V,14脚是ACOK 有3.3V。19 20有5.05V 25脚自举电压有16.8V,现在疑问是26脚是16V。装不装电池测试26脚电压都为16V,用14.5V的适配器时为14.5V 说明适配器电流小于0.15A!

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-11-30 22:31 | 显示全部楼层
可乐炖香烟 发表于 2018-11-30 20:39
我觉得问题出在 2.8V 这个信号  电压有些低,楼主沿着这个方向 查下去,肯定有收获。

用14.5V的适配器时 这个点的电压为3.2V,难道是适配器问题?手上没有原装适配器!

回复 支持 反对

使用道具 举报

发表于 2018-12-1 09:30 | 显示全部楼层
6259 的17-18脚   看看电压是否正常,看看电阻是否  2.2 0 欧

回复 支持 反对

使用道具 举报

发表于 2018-12-1 10:16 | 显示全部楼层
5605245 发表于 2018-11-30 22:00
2脚DCIN 16.3V,3脚ACin有3.3V,10 11J脚系统总线时钟电压有3.3V,13脚是总线复位有3.3V,14脚是ACOK 有3.3 ...

如果有 现在没有头绪我推荐你更换6295  ,最好是料板拆机的。这个6295 坏的好多,

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-1 14:35 | 显示全部楼层
本帖最后由 5605245 于 2018-12-1 14:39 编辑
刘慧杰 发表于 2018-12-1 09:30
6259 的17-18脚   看看电压是否正常,看看电阻是否  2.2 0 欧

电压会随着公共点电压变化而变化。阻值都算正常吧,没有精密万能表。普通表测试 3 和 0 欧

回复 支持 反对

使用道具 举报

发表于 2018-12-1 15:02 | 显示全部楼层
5605245 发表于 2018-12-1 14:35
电压会随着公共点电压变化而变化。阻值都算正常吧,没有精密万能表。普通表测试 3 和 0 欧

2.2  0 欧 测正常电压 多半都在 8.X    充电问题一半都是  电阻坏  

回复 支持 反对

使用道具 举报

发表于 2018-12-1 15:05 | 显示全部楼层
刘慧杰 发表于 2018-12-1 15:02
2.2  0 欧 测正常电压 多半都在 8.X    充电问题一半都是  电阻坏

指示灯的那排线坏 和进水腐蚀  我遇到不触 发的  断开  试一下  最好单板测试下   SMC  看下条件看看EC

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-1 15:22 | 显示全部楼层
刘慧杰 发表于 2018-12-1 15:05
指示灯的那排线坏 和进水腐蚀  我遇到不触 发的  断开  试一下  最好单板测试下   SMC  看下条件看看EC

单板和接电池测试了  都一样!真没头绪了,修苹果笔记本比较少。。。。电池接口的两个识别信号时钟的我用示波器测试有跳变点波。拨了适配器波会消失。EC这边主要要测试那几个信号呢?

回复 支持 反对

使用道具 举报

发表于 2018-12-1 16:17 | 显示全部楼层
不懂苹果本,不过看着论坛里面还是有大神的

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-3 15:50 | 显示全部楼层
可乐炖香烟 发表于 2018-11-30 20:39
我觉得问题出在 2.8V 这个信号  电压有些低,楼主沿着这个方向 查下去,肯定有收获。

我去买适配器的店里借来原装的试了,,也是不充电!!!!

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-3 15:51 | 显示全部楼层
可乐炖香烟 发表于 2018-12-1 10:16
如果有 现在没有头绪我推荐你更换6295  ,最好是料板拆机的。这个6295 坏的好多,

网上6块一个说是原装的 买回来 换了,,情况也一样!!!!耐心快没了。。。。

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长提醒 上一条 /1 下一条