迅维网

查看: 418|回复: 4
[维修经验]

联想e420不触发非常难修

  [复制链接]
发表于 2021-8-15 21:07:37 | 显示全部楼层 |阅读模式

马上注册,获取阅读精华内容及下载权限

您需要 登录 才可以下载或查看,没有帐号?注册

x
故障是待机3 5v都有,也有pg输出,排除d95280芯片问题。这款机如果没有记错,应该是3 5v出来以后,ec收到pg,并且读取到正确的bios程序,会关闭掉3 5v,但是这个机子一直保持。

示波器测试bios芯片,1 5 6都有一瞬间波形,2脚没有输出,7 8高电平,刷bios。正常,冷机又不正常,最后发现是只要加热bios芯片2 3脚位置就能正常开机,只要不是关机再开,重启什么的都一切正常。

换过bios芯片。检查bios芯片所有引脚间也没有漏电,搞得头晕眼花了。

既然重启都能正常读取bios,那就不是引脚间漏电,感觉有点绕进去了,换个维修方式。插电,镊子短接ec芯片的44脚电容或者手动拉低ecrst复位再松开,每次都能正常读取bios上电开机。
自此判断是时序问题,但是加热bios芯片这个我是没想明白。
经过一系列调试,最终的方案是把ecrst复位信号的上拉电阻供电端移到旁边的电阻也就是开关电源3.3v,原先的上拉电压是待机芯片d95280的ldo3.3v,这样就可以让ec的工作条件都ok了复位才出来,还要把ec的14脚抬起来,不然会造成单用电池第一次无法正常开机,因为ec没有检测到acin适配器接入信号进入省电模式,没有开启3 5v,ec没有得到复位也就不工作了。缺点就是单用电池的话关机状态也会缓慢掉电,忽略不计,我只管赚钱养家了。

修到最后论坛搜索,好像发现这款机这个问题也是通病,论坛貌似没有人能解决或许没有放出解决方案吧。
Ecrst我还加了个电容做延时,上拉电阻也更换成大的,那个是之前调试的,但是没有效果,后来确定问题也就懒得再改回去了,也是一样用,心好累。

                               
登录/注册后看高清大图


                               
登录/注册后看高清大图


                               
登录/注册后看高清大图


                               
登录/注册后看高清大图


                               
登录/注册后看高清大图


评分

参与人数 1下载分 +3 收起 理由
天意wx + 3 给愿意分享经验的人加分!

查看全部评分

发表于 2021-8-15 22:09:25 | 显示全部楼层
牛逼克拉斯

回复 支持 反对

使用道具 举报

发表于 2021-8-16 09:16:32 | 显示全部楼层
应该换个EC看看,因为强制拉高复位是没有办法的办法。

点评

瞎几把回复  详情 回复 发表于 2021-8-16 13:03
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-8-16 13:03:10 来自迅维网APP | 显示全部楼层
873808892 发表于 2021-08-16 09:16
应该换个EC看看,因为强制拉高复位是没有办法的办法。

瞎几把回复

回复 支持 反对

使用道具 举报

发表于 2021-8-19 11:52:42 | 显示全部楼层
有示波器就是好,,,,,,,,,,,,,,,,,,,,,

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回顶部 返回列表
附近
店铺
维修
报价
信号元
件查询
点位图


全文搜索

快速回复