迅维网

查看: 1462|回复: 6
[维修经验]

二修索尼DA0HKDMB6D0 VR_READY信号不正常掉电故障

  [复制链接]
发表于 2020-1-15 10:22:22 | 显示全部楼层 |阅读模式
  板号:DA0HKDMB6D0 REV

  故障:0.0400A-1700A掉电 二修

011520_0212_DA0HKDMB6D01.png

  主板正面图

  观察有过维修痕迹

  1、EC整体有焊接痕迹

  2、EC旁的KR12电阻被拆,用线直连了
011520_0212_DA0HKDMB6D02.png

  3、BIOS有焊接痕迹

  4、内存供电芯片有焊接痕迹

  防止有做故障误导维修,先还原主板原来的样子,EC动过所以先拆EC,发EC底部被断线。

011520_0212_DA0HKDMB6D03.png

  这根线没补,担心焊接EC时有影响,留着从EC外飞线就可以了,因为这是80pin  恰好就是SUS_ON,可以从80pin直飞内存供电的开启。


011520_0212_DA0HKDMB6D04.png


  这条线从80pin飞到内存供电的16pin外的PC129焊盘上就好了。

011520_0212_DA0HKDMB6D05.png


  EC旁边的KR12是直连的,防止有问题也换成电阻,把KR12换一个4K的电阻回去(没找到2K的电阻),发现这条线也被隔断,这条线是PCH_PWROK_EC  到桥的,经过了二极管KD4。
01.jpg


011520_0212_DA0HKDMB6D07.png

  线就从KR12飞到KD4,飞好是这样的。

01.jpg


011520_0212_DA0HKDMB6D09.png


  飞好之后,通电测试,电流0.0400-0.2000A随机掉电,这种随机电流掉电是因为掉电速度太快,电流表只能显示一点,所以电流就很随机了。

  多次测试,电流最高能到0.2000A,姑且认为0.2000A掉电,首先看看有没有那组供电没有出,经过测量只有PL9没有出,也就是内存供电没有发出,打内存供电电感,只有24,去掉内存条阻值正常,说明内存短路,不装内存条,上电还是同样的电流掉电,所有电感电压都出了。

  掉电速度太快,万用表跟不上,直接上示波器比对掉电时间,首先我们要知道SLP_S3#对应EC发出SUS_ON,SLP_S4#对应EC发出RUN_ON,根据官方提供的图可以知道SUS_ON只开启了内存供电,RUN_ON开启了其他的所有供电当然除去CPU和GPU。

011520_0212_DA0HKDMB6D010.png

  SUS_ON和RUN_ON是同时掉的,我们视为同一个信号,用SUS_ON/RUN_ON去对比内存1.35V电感后端。

01.jpg


01.jpg


  很明显,SUS_ON掉电后内存才开始掉的,排除内存供电导致,SUS_ON再对比1.05V供电。

01.jpg


  仍然是SUS_ON先掉后,1.05V才开始掉,也排除1.05V导致故障,CPU和GPU都是分开的开启信号,也对比几个PG都正常。

01.jpg


  都是SUS_ON先掉,CPU必定是检测的什么才会停止输出S4和S3的,再对比SUS_ON和EC_WAKE_ON和DEEP_EC_EN。
01.jpg


  这两个信号一个是控制35V的发出,一个是35V后继供电的开启,都是SUS_ON先掉,二级电压也都正常,再测CPU供电,也出了,CPU供电PG信号瞬间也有电。

011520_0212_DA0HKDMB6D016.png

  在论坛找了一张时序图。

011520_0212_DA0HKDMB6D017.png

  从时序图可以知道28步是IMVP_PWRGD发给PCH的(在我这里是发到CPU,因为这是单U芯片组),29步和30步都是PCH到CPU(那在单U芯片组就是CPU内部完成了)直接到31步,是VRM芯片和CPU之间交换的SVID数据,示波器测量VRM芯片的3脚,VR_SVID_DATA,只有电平变化,没有任何波形。


011520_0212_DA0HKDMB6D018.png

  这样就可以判断,故障产生就在IMVP_PWRGD发出之后,SVID之前,CPU内部完成的信号没办法测量,也只能判断CPU损坏,但是我们可以看IMVP_PWRGD去了那里,通过搜索只去了Q3这一个地方。

011520_0212_DA0HKDMB6D019.png

  4pin-5pin阻值581  1pin-6pin阻值581,R44和R43在路测量都是100K,元件都正常,示波器测量3pin有3.3v-0V的电平变化是正常的,然后测量VR_READY的时候,电压只有1V不到,正奇怪呢。电流突然可以上到0.5500A,然后掉电了,之后每次通电都可以上到0.5500A后掉电,难道这个故障就好了?SM BUS也瞬间有了波形。

01.jpg


  内存复位也有了,装内存0.8A掉电不装0.6A掉电,先刷bios,因为bios也动过,刷完故障依旧,除了判断CPU坏,只有EC现在是动过的,而且被拆过,好坏也未知,供电芯片虽然动过,但是供电都正常,于是换新EC上去,重新飞线。

01.jpg


  再通电开机正常。

01.jpg


  对于掉电的机器,示波器通过这样的对比可以快速锁定故障点,如果对比到某个供电比SUS_ON先掉了,那必定是这个供电电路的问题,对应去更换该电路的芯片,或者检查其工作条件就可以了。

  当然,修这个机器,中间远远不止查了这些,包括温控,ALL_SYS_PWRGD(HWPG),PCH_PWROK_EC都查了,绕了很大弯,现在从分析来看,可能是Q3 MOS管有静电(没有依据,猜测,因为索尼有很多保护电路),EC本身是确实损坏,当然也有可能是上家吹坏了,因为看上家动过的KR12、KD4等元件来看,其思路是正确的,但是他没有测到IMVP_PWRGD这一步所以没有修好,我在论坛也看到有不少索尼类似故障最后没有解决的,希望大家下次遇到索尼机器,多注意下这种情况,我遇到已经有3台索尼是这种情况修好的。

  亮机图:

01.jpg

iPhone 11 Pro维修图纸资料已上传鑫智造!
扫码注册即可使用!
↓ ↓ ↓

  鑫智造维修查询工具一款手机电脑平板都囊括,查图纸、查点位图、查通病、自学维修知识等通通都有,资料更新快,支持双开,无需加密狗,不绑定电脑,支持多账号随时随地同时登录。点击链接:http://www.wmdang.com/index/index/introduce/inviter/1995.html 手机号注册,电脑端下载。

鑫智造.jpg


评分

参与人数 6下载分 +19 金币 +11 收起 理由
873808892 + 5 精品文章
天意wx + 3 给愿意分享经验的人加分!
xj3121 + 2 + 2 老司机!双击666+关注.....
fix3366 + 5 + 5 太NB了吧,二修掉电机的大佬,学习了~
xiaowu2015 + 2 + 2 给愿意分享经验的人加分!
海成科技1888 + 2 + 2

查看全部评分

发表于 2020-1-15 10:29:41 | 显示全部楼层
教程级别的帖子            

回复 支持 反对

使用道具 举报

发表于 2020-1-15 12:02:52 | 显示全部楼层
楼主可以写个教程了,佩服

回复 支持 反对

使用道具 举报

发表于 2020-1-17 19:50:31 | 显示全部楼层
好经验!谢谢楼主的分享!!

回复 支持 反对

使用道具 举报

发表于 2020-2-1 10:10:56 来自迅维网APP | 显示全部楼层
非常好的经验。掉电没有示波器真的难搞。

回复 支持 反对

使用道具 举报

发表于 2020-2-1 11:59:21 | 显示全部楼层
这机器最好多测一段时间,再交客户,那个q3如果是我就把它换掉,有的管子如果特性不好,出问题万用表测不出,楼主信号级维修功底深厚。太有耐心了,向你学习。

回复 支持 反对

使用道具 举报

发表于 2020-2-1 12:52:39 | 显示全部楼层
有个示波器,但是大部分时间在吃灰,是时候让他发挥作用了, 楼主讲得非常好, 有理论走遍天下都不怕

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回顶部 返回列表
附近
店铺
维修
报价
信号元
件查询
鑫智造


全文搜索

快速回复