迅维网

查看: 458|回复: 11
[笔记本电脑]

HP4410S认到声卡无声音维修

  [复制链接]
发表于 2021-4-29 12:05:36 | 显示全部楼层 |阅读模式
一块HP4410S主板,进系统后在设备管理器中认到声卡,而且声卡驱动也安装正常,桌面上喇叭图标也显示正常,就是没有任何声音。
在网站上也找不到此机的图纸,看声卡芯片是92HD87B2X5NDGXRAX-GP-U1,此主板版型与HP 4446S(11242-1)相似,声卡那块电路是一样的。于是参考HP4446S电路。
image.png image.png image.png
首先测量喇叭口电平值均有2.5V左右的电压,放声音时用示波器测量发现就是一个直流电平值无任何波动。再测92HD87B2X5NDGXRAX-GP-U1各个脚位电压参数,发现基本上都正常,仅仅发现21、32脚的供电AVDD_CODEC为4.7V,与33、39脚位的5V供电5V_S0略低一点,而21、32脚和33、39脚位的供电之间就是加了一个Q2902电压转换芯片,没有道理不一样啊!
image.png
再看经过电压转换芯片Q2902出来的5V电压除了给芯片的21、32脚供电外,还给耳机检测、机内蜂鸣器电路供电,断开机内蜂鸣器电路供电仍为4.7V,再断开耳机检测电路R2915(2K49R2F-GP)发现电压升到5V正常了,看来是耳机检测电路有问题。再连接上电路R2915(2K49R2F-GP),分别断开R2913(20KR2F-L-GP)和R2919(10KR2F-2-GP),发现R2913电路有问题。断开R2913后AVDD_CODEC升到了5V,测量R2913阻值20K也正常,再测量其两端电压,呵呵,问题暴露出来了,R2913左端4.7V,右端只有0.2V。看电路R2913右端与AUDIO1端口的23脚相连,不接小板的情况下应该为无穷大的阻值。奇怪了看电压情况应该是R2913右端被间接近似接地将电压拉低了,从而相当于检测插入了耳机从而关闭了喇叭输出。只好在电路板上找了,最后发现在声卡背面装了一个小电容,一端接地,另外一端与R2913右端(AUDIO1端口的23脚)相连。拆掉此电容,电路恢复正常,更换此电容,再加电进系统测试,声音终于正常了。

评分

参与人数 2下载分 +4 金币 +1 收起 理由
Linshengqiang + 1 + 1 给愿意分享经验的人加分!
天意wx + 3 给愿意分享经验的人加分!

查看全部评分

发表于 6 天前 来自迅维网APP | 显示全部楼层
现在的声卡都集成功放了,

回复 支持 1 反对 0

使用道具 举报

发表于 7 天前 来自迅维网APP | 显示全部楼层
楼主分析的很透彻

回复 支持 1 反对 0

使用道具 举报

发表于 7 天前 来自迅维网APP | 显示全部楼层
高手
就是不一样

回复 支持 1 反对 0

使用道具 举报

发表于 7 天前 | 显示全部楼层

现在的声卡都集成功放了,换芯片又容易吹坏

回复 支持 1 反对 0

使用道具 举报

发表于 2021-4-29 15:24:29 | 显示全部楼层
现在的声卡都集成功放了,换芯片又容易吹坏

回复 支持 1 反对 0

使用道具 举报

发表于 2021-4-29 15:10:20 | 显示全部楼层
细节可以学习了

回复 支持 1 反对 0

使用道具 举报

发表于 2021-4-29 14:54:00 | 显示全部楼层
耳机检测电路,芯片误以为耳机插入,

回复 支持 1 反对 0

使用道具 举报

发表于 2021-4-29 13:17:40 | 显示全部楼层
希望多发些文章维修经验

回复 支持 1 反对 0

使用道具 举报

发表于 2021-4-29 13:17:17 | 显示全部楼层
谢谢分享 思路很重要

回复 支持 1 反对 0

使用道具 举报

发表于 2021-4-29 12:47:48 | 显示全部楼层
认真分析 思路清晰

回复 支持 1 反对 0

使用道具 举报

发表于 2021-4-29 12:14:44 | 显示全部楼层
技术精湛,感谢分享

回复 支持 1 反对 0

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回顶部 返回列表
附近
店铺
维修
报价
信号元
件查询
点位图


全文搜索

快速回复