开启辅助访问

QQ登录

只需一步,快速开始

注册 找回密码 切换到宽版 |

迅维网

查看: 350|回复: 19
[求助中]

两台苹果一样的故障,自动切换到电池模式

[复制链接]
发表于 2018-12-3 19:16 | 显示全部楼层 |阅读模式

马上注册,阅读更多精彩内容

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 陈祖平 于 2018-12-3 19:18 编辑

  一台A1286,版号820-2850-A.一台A1278,版号820-2936-B,都是一样的故障现象,电源和电池同时用,开机自动切换到电池模式,单用电源,开机不定时掉电,有时两分钟左右,有时触发就掉电,单用电池OK。

  ACOK有只有0.6V,ACIN3.6VOK的。将和ACOK相连的所有的原件(除了SMC以外)去掉还是只有0.6V。充电IC是ISL6259也换了几个还是一样

论坛里有人说R7051,R7052也换了还是一样。ACOK的上拉电阻也换了,还是一样
怀疑是SMC拉低ACOK。于是一样淘了一块料板回来,直接测试料板,两块料板的ACOK也是0.6V。这很就郁闷了,四块板子都是一样的ACOK只有0.6V
以前没修到过这个这种故障,难道苹果的ACOK本来就是0.6V是正常的?
另外也试过将ACOK的上拉电阻从470K换成100欧姆的,这时ACOK变成3.3V,但还是一样开机自动切换成电池模式。
本来想换SMC的,但发两块料板回来还是一样的ACOK只有0.6V。估计换了也不会好。实在没辙了特来求助。有知道的朋友指点下或者提供点思路都好
另外还有台DELL 15R-5521的机器,装显卡驱动蓝屏,换了新的显卡,8颗现存,还是一样蓝屏。取了显卡,对照点位,所有的电源引脚都
一个个测试没有问题。但就是装显卡驱动就蓝屏。刷了BIOS,换了内存,硬盘,显卡,8颗显存,一样都是装显卡驱动就蓝屏,搞了五天,
还是没搞定最后退给客人了,修的真想骂娘。CPU是板载的,不知道会不是CPU问题。但不装显卡驱动,完全OK的。

本文由 陈祖平 原创或被授权转载制作,其他机构或个人未经许可严禁转载。

评分

参与人数 1下载分 +2 金币 +2 收起 理由
xiaohuaifu + 2 + 2 给愿意分享经验的人加分!

查看全部评分

发表于 2018-12-3 20:02 | 显示全部楼层
AC没有检测到?AC电源识别脚的信号?AC功率检测电阻?充电芯片无法切换,重点查充电芯片外围电路。都正常换SMC

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-3 20:05 | 显示全部楼层
873808892 发表于 2018-12-3 20:02
AC没有检测到?AC电源识别脚的信号?AC功率检测电阻?充电芯片无法切换,重点查充电芯片外围电路。都正常换S ...

ISL6259周边的都是检查过的没问题,功率检测电阻,反馈电阻都是OK的,ACIN有3.6V也是OK的

回复 支持 反对

使用道具 举报

发表于 2018-12-3 20:15 | 显示全部楼层
中间针信号呢?SYS_ONEWIRE有不?

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-3 20:18 | 显示全部楼层
873808892 发表于 2018-12-3 20:15
中间针信号呢?SYS_ONEWIRE有不?

能亮绿灯,一会变成黄灯,充电冲一会就停,但没检查这个SYS_ONEWIRE,明天去了看看

回复 支持 反对

使用道具 举报

发表于 2018-12-3 20:26 | 显示全部楼层
还有第二个隔离管,有可能是小电池导通?

回复 支持 反对

使用道具 举报

发表于 2018-12-3 20:37 | 显示全部楼层
我也碰到一台DELL的,满屏黑点,集显独显驱动都不装就就正常,也没有修退给客户了。

回复 支持 反对

使用道具 举报

发表于 2018-12-3 21:01 | 显示全部楼层
通常这些故障都是细小的地方的问题,要好好检查才行

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-3 21:05 | 显示全部楼层
873808892 发表于 2018-12-3 20:26
还有第二个隔离管,有可能是小电池导通?

就是单独用电源的时候,电池放电MOS管的控制都只有4.8V,正常的话应该是12V左右,用电池的时候才是5V左右

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-3 21:05 | 显示全部楼层
xiaohuaifu 发表于 2018-12-3 20:37
我也碰到一台DELL的,满屏黑点,集显独显驱动都不装就就正常,也没有修退给客户了。

满屏黑点应该是显存的问题,我以前修过

点评

下次碰到试下,                              详情 回复 发表于 2018-12-4 09:26
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-3 21:06 | 显示全部楼层
小汇 发表于 2018-12-3 21:01
通常这些故障都是细小的地方的问题,要好好检查才行

ISL6259周边的都检查过了,都是OK的,就是ACOK不对

回复 支持 反对

使用道具 举报

发表于 2018-12-3 21:11 | 显示全部楼层
这个DELL的这个机器我刚刚也搞了一台,大爷的显卡感叹号,显卡换了也一样,亏了,还不如开始就换主板,苹果那个ACOK不正常,电源指示灯状态正常吗、

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-3 21:17 | 显示全部楼层
本帖最后由 陈祖平 于 2018-12-3 21:19 编辑
376446567 发表于 2018-12-3 21:11
这个DELL的这个机器我刚刚也搞了一台,大爷的显卡感叹号,显卡换了也一样,亏了,还不如开始就换主板,苹果 ...

是呀,那个DELL15R-5521真的想骂娘,修这么多年,还是第一次遇到显卡驱动装不上的搞不定,关键我把显卡
取下来,对照点位一个个脚测试过了。电压都有,也没开路短路的,就是搞不好,也是郁闷了。
苹果的两个机器都是电源指示灯都是OK的,刚插上绿灯,一会就变成黄灯,用可调电源看电流的话,充电电流
从0.4一直到1.8A左右就掉下来,然后又这样循环。多循环几次就变成0.2左右,一旦开机的话可调的电流就变成0.06单用电源开机的话,有时能进系统使用一会,就掉电,有时一触发就掉电。

回复 支持 反对

使用道具 举报

发表于 2018-12-4 07:19 | 显示全部楼层
其实就是充电器问题吧

回复 支持 反对

使用道具 举报

发表于 2018-12-4 09:26 | 显示全部楼层
陈祖平 发表于 2018-12-3 21:05
满屏黑点应该是显存的问题,我以前修过

下次碰到试下,                            

回复 支持 反对

使用道具 举报

发表于 2018-12-5 09:33 | 显示全部楼层
ACOK 问题  MSC 的反馈 和 线路查下  看下 3.42V 输出 电压   还有不要忘记 替换下 声卡小板排线

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-5 12:03 | 显示全部楼层
刘慧杰 发表于 2018-12-5 09:33
ACOK 问题  MSC 的反馈 和 线路查下  看下 3.42V 输出 电压   还有不要忘记 替换下 声卡小板排线

刚搞好了 一台,跟ACOK无关,修好了以后ACOK还是0,6V,还有一台没搞好,搞好了有空在发个贴

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-12-5 12:04 | 显示全部楼层
¤我的最爱¤ 发表于 2018-12-4 07:19
其实就是充电器问题吧

明显是主板问题,怎么回事适配器问题呢,

回复 支持 反对

使用道具 举报

发表于 2018-12-10 09:40 | 显示全部楼层
学习了不错了               

回复 支持 反对

使用道具 举报

发表于 2018-12-12 06:11 来自手机 | 显示全部楼层
你说的acok是smc_bc_ok这个信号吧?看见主板预留的一个电阻位了么?一端接的pp3v42h,一坨锡直连即可,如果还不行,查检流电阻,这两个电阻也容易变质,如果不好你再找我

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长提醒 上一条 /1 下一条