迅维网

查看: 480|回复: 17
[求助中]

开关电源高手请进,神奇的故障现象

  [复制链接]
发表于 2021-7-12 16:10:49 | 显示全部楼层 |阅读模式

马上注册,获取阅读精华内容及下载权限

您需要 登录 才可以下载或查看,没有帐号?注册

x
      一、故事前戏:之前没事摆弄一炸管400W-ATX电源,被动PFC,前级高压开关管13009半桥,低级UTC7520,更换13009和保险管后,测输入输出均无短路,就上电,待机两个电压均正常,无奈不启动,于是各种检查,主开关管基极电路,变压器T1T2,后级推动电路,芯片7520的几个保护电路的原件等等,均无异常,就是不启动,7520的PWM两个输出电压为2.3V异常,其它各脚待机电压正常,怀疑芯片坏,某宝买两个WT7520(查资料说可以代换),更换第一个依然不启动,拆下扔掉换第二个,还是不启动,偶尔一次检查挂带灯的负载风扇时发现短接启动开关时风扇虽然不转,但是风圈上的LED灯很暗的亮了一下就熄灭,于是查开机12V电压,瞬间上到3V然后就马上降下去为0了,感觉是启动就立即保护了或者震荡很弱荡不起来的感觉,于是又查各种保护电路,更换推动管,检查调整输出电压反馈脚分压电阻阻值,依然无果,故障现象依旧,于是作罢扔一边当料板。
    二、神奇现象发生:最近无聊,不心甘修不好一个ATX,于是又翻出来检查,重复之前的各种检查,包括外接12V,5V,3.3V,-12V,均找不到故障原件,于是还是怀疑芯片7520有问题,由于手里没更换件,就突发奇想,想看看7520的两个PWM输出脚究竟输出电压是多少?(一直是不管待机还是短接开机这两个脚都稳稳的2.3V无变化),于是拆掉了两个推动N管基极的上偏置电阻2.7K,这样推动管基极就只和芯片的PWM输出脚相连了。插电,待机,测得两个输出脚电压为0.8V左右,当我继续检查其它脚位的待机电压时,神奇的事情发生了,我发现我掌着整流二极管散热器的手感觉到有点烫了,当下大惊,有短路,赶快拔插头断电,随后我反复检查前后级,没有任何地方短路呀,于是大着胆子又上电,一会儿散热器和电容又发烫,反复无数次,全这样。几个神奇的想象:
1、只上电并没有短接绿线,超压输出时绿线仍然是5V电压。
2、几次测试发现上电后并没有马上输出电压,刚上电时7520输出脚为0.8V,各组输出均为0,但是十几秒后,PWM脚电压由0.8迅速下降为0,输出电压就出来了,而且是翻番高的电压,正负12V成了27V,5V变成了11V,3.3V变成了7V,并且镇流二极管散热片和滤波电容立即发烫,没敢再持续检查输出电压是否还会升高。
     现在可以明确是芯片7520坏了吧?某宝买的两个拿上去都是坏的,但是这故障现象太神奇了,不需短接绿线,且延时十几秒自启,输出的又是不受控的高电压,还有,有输出时PWM脚也就是推动三极管的基极电压为0,这可是N管呀?N管基极电压为0怎么工作的?我被彻底弄糊涂了,于是把推动管的上偏置电阻装回去,故障现象又恢复原状,不启动了。
     前后迥然的故障现象就是我装和不装推动管上偏置电阻的结果,我实在搞不懂发生了什么,有开关电源高手能否解答下,感谢!

                               
登录/注册后看高清大图


 楼主| 发表于 2021-7-14 10:25:27 来自迅维网APP | 显示全部楼层
新买的7520到了,换上去故障依然,仍然短接绿线后12V输出输出到2V多就开始往下走,几秒后就停摆了。

回复 支持 4 反对 0

使用道具 举报

 楼主| 发表于 2021-7-13 11:40:52 来自迅维网APP | 显示全部楼层
目前我是这样理解的,不知道对不:抛开芯片自身问题-不短接绿线可以启动、安全保护失效,只来探讨下去掉NPN推动管基极上拉电阻对振荡的影响。后级各组电压输出高,意味着占空比高,就是主开关管上管导通时间长,下管截止时间短,而驱动电路一般是反激电路,那就意味着推动管截止时间长,导通时间短,而电源管理芯片输出脉冲幅度不够,在拆掉推动管基极上拉电阻后,推动管导通时间就短了,截止时间长了,于是推动管基极脉冲电压测出来也接近0了。

回复 支持 4 反对 0

使用道具 举报

 楼主| 发表于 2021-7-12 16:14:39 来自迅维网APP | 显示全部楼层
就拆两个推动管的上偏置电阻,电源就从不启动不振荡变成了不开就自己启动,还是延时自行启动,并且输出电压不受控,闯鬼了。

回复 支持 3 反对 0

使用道具 举报

发表于 2021-7-13 12:06:59 | 显示全部楼层
学习了,太深奥。。。。。。

回复 支持 2 反对 0

使用道具 举报

发表于 2021-7-19 18:09:38 | 显示全部楼层
qhyxycq 发表于 2021-7-16 11:57
昨天又试了下拆掉两个推动N管的上偏置电阻,不用短接绿线,上电,不会自己启动,只有用表笔去测量推动基极 ...

推动管2.3V说明7520没PWM输出,有输出应该是1.8V左右,断开上拉驱动电阻后,用表笔测基极会引入杂波形成振荡,电源就被驱动了

点评

我琢磨也是跳开PSON形成不受控的自激振荡了  详情 回复 发表于 2021-7-19 20:26
回复 支持 1 反对 0

使用道具 举报

发表于 2021-7-16 09:21:11 来自迅维网APP | 显示全部楼层
电源是怎么坏的,你没说清楚,.

点评

怎么坏的?难道电源会告诉我为什么坏了?  详情 回复 发表于 2021-7-16 11:58
回复 支持 1 反对 0

使用道具 举报

发表于 2021-7-15 10:29:48 | 显示全部楼层
这个貌似不懂,兜一圈支持一下楼主

回复 支持 1 反对 0

使用道具 举报

 楼主| 发表于 2021-7-16 11:57:53 来自迅维网APP | 显示全部楼层
昨天又试了下拆掉两个推动N管的上偏置电阻,不用短接绿线,上电,不会自己启动,只有用表笔去测量推动基极电压时,它就自己开始振荡了,依然是瞬间就达到正常输出电压的两倍,而且电流很大,散热器镇流二极管滤波电容甚至连跳线铁丝都发烫,不敢进一步测试,赶忙断电。

点评

推动管2.3V说明7520没PWM输出,有输出应该是1.8V左右,断开上拉驱动电阻后,用表笔测基极会引入杂波形成振荡,电源就被驱动了  详情 回复 发表于 2021-7-19 18:09
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-7-16 11:58:39 来自迅维网APP | 显示全部楼层
王华峰 发表于 2021-07-16 09:21
电源是怎么坏的,你没说清楚,.

怎么坏的?难道电源会告诉我为什么坏了?

                               
登录/注册后看高清大图

回复 支持 反对

使用道具 举报

发表于 2021-7-16 12:06:40 来自迅维网APP | 显示全部楼层
怎么感觉有寄生振荡自激啊!各种保护电路及元件好好查查!

点评

首先想到的就是保护电路呀,挨个拆光了都没发现异常变值的原件  详情 回复 发表于 2021-7-16 21:50
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-7-16 21:50:28 来自迅维网APP | 显示全部楼层
wsczjdy 发表于 2021-07-16 12:06
怎么感觉有寄生振荡自激啊!各种保护电路及元件好好查查!

首先想到的就是保护电路呀,挨个拆光了都没发现异常变值的原件

                               
登录/注册后看高清大图

回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-7-19 17:47:36 来自迅维网APP | 显示全部楼层
UTC7520和WT7520直接代换有点问题,替换后一直无法开机,短接绿线风扇都不转,测得轻微起振就马上保护了,最后查出是4脚PT(0.8V)过载保护,这个过载保护是从T2接推动管集电极整流过来分流取样,将取样上分压电阻调大后保护取消,完美修复。

点评

这种故障可以很明显能确定是上电保护,对着芯片资料查一下就可以知道是哪里问题了  详情 回复 发表于 2021-7-19 18:11
回复 支持 反对

使用道具 举报

发表于 2021-7-19 18:11:00 | 显示全部楼层
qhyxycq 发表于 2021-7-19 17:47
UTC7520和WT7520直接代换有点问题,替换后一直无法开机,短接绿线风扇都不转,测得轻微起振就马上保护了, ...

这种故障可以很明显能确定是上电保护,对着芯片资料查一下就可以知道是哪里问题了

点评

问题就出在网上找不到UTC7520的资料  详情 回复 发表于 2021-7-19 20:26
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-7-19 20:26:08 来自迅维网APP | 显示全部楼层
春湾扬洲电脑 发表于 2021-07-19 18:09
推动管2.3V说明7520没PWM输出,有输出应该是1.8V左右,断开上拉驱动电阻后,用表笔测基极会引入杂波形成振荡,电源就被驱动了

我琢磨也是跳开PSON形成不受控的自激振荡了

回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-7-19 20:26:51 来自迅维网APP | 显示全部楼层
春湾扬洲电脑 发表于 2021-07-19 18:11
这种故障可以很明显能确定是上电保护,对着芯片资料查一下就可以知道是哪里问题了

问题就出在网上找不到UTC7520的资料

点评

有资料,7520尾就行,前缀不需要一样  详情 回复 发表于 2021-7-20 18:27
回复 支持 反对

使用道具 举报

发表于 2021-7-20 18:27:56 | 显示全部楼层
qhyxycq 发表于 2021-7-19 20:26
问题就出在网上找不到UTC7520的资料

有资料,7520尾就行,前缀不需要一样

点评

引脚功能一样不一定表示外围原件参数没差异呀  详情 回复 发表于 2021-7-20 19:09
回复 支持 反对

使用道具 举报

 楼主| 发表于 2021-7-20 19:09:46 来自迅维网APP | 显示全部楼层
春湾扬洲电脑 发表于 2021-07-20 18:27
有资料,7520尾就行,前缀不需要一样

引脚功能一样不一定表示外围原件参数没差异呀

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回顶部 返回列表
附近
店铺
维修
报价
信号元
件查询
点位图


全文搜索

快速回复