开启辅助访问

QQ登录

只需一步,快速开始

注册 找回密码 切换到宽版 |

迅维网

查看: 600|回复: 16
[已解决]

首发论坛无人解决的B520E 耳机有声音喇叭没声音故障

  [复制链接]
发表于 2018-10-25 12:42 | 显示全部楼层 |阅读模式

马上注册,阅读更多精彩内容

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 学文张 于 2018-10-25 12:44 编辑

机器型号:联想10088 B520E 不带TV
机器版号:LA-7811P REV:1.0
机器故障:正常显示 耳机有声音 喇叭没声音
维修过程:修东西第一步先看看论坛有没有通病,搜索了下 有2个也是这个故障的不过没有解决  有说图纸上没有这个功放芯片的pdf的 其实是有的 不过图纸上是一个功放 而主板上有3个功放,位置号不一样搜索ALC106就行。
按照时序修吧 一般耳机有声音喇叭没声音先看看是不是耳机插孔的问题,打开图纸找到耳机插入信号如下图
1.jpg 2.jpg

在声卡芯片alc663  34脚测得HP_PLUG#信号正常 低电平有效,用示波器测得ALC663的 35和36脚有声音波形输出送到了功放芯片ALC106的12脚和13脚,
3.jpg
由此可以判断声卡应该没问题 ,看了是功放这边的问题。
先测量供电4 5 16脚pvdd供电5v正常 1脚3.3v供电正常
4.jpg
再测量9脚静音信号3v正常,10脚不知道什么信号和9脚都是低电平有效 测得也是高电平 应该正常  11脚是pvdd经两个5.1k电阻分压2.47v正常,12 13脚声音输入刚才说过了正常 14 15 脚是通往ec的测得3.3v 示波器没量到什么波形不知道正不正常
5.jpg
看来功放坏的几率很大啊  但是想想 不可能3个都坏掉啊     因为里面有5组喇叭  至少得有响的啊?   或许有1个坏了影响的  先换掉再说吧  没现货 订货    到货后装上还是一样   这就奇怪的哪里的问题呢?
现在唯一怀疑的就是功放14 15脚VOL_SCL_AMP和VOL_SDA_AMP 这两个信号了 和ec通讯的 具体作用不知道,  是不是ec的问题呢   手上没有  心想先刷个ec bios吧  刷完后  奇迹出现了     有声音了,我都不敢相信 是真的  是不是巧合  为了确认 我又把 原机刷回去 又没声音了 再刷回来 又好了  看来就是 ec bios 的问题   还是第一次修到ecbios会导致 喇叭没声音呢  修好后测量 14 15脚插拔耳机也没测得什么波形不知道怎么工作的还是我没测对
论坛有几个也是这个故障没有解决   我修了好久才修好  希望大家多多加分支持下
奉上 bios 和图纸  bios 里面有3个  一个是 ec 一个是pch 的还一个是驱动显示部分 的 都确认过是好的了  放心下载
b520e_Compal_LA-7811P.pdf (878.93 KB, 下载次数: 5)

本文由 学文张 原创或被授权转载制作,其他机构或个人未经许可严禁转载。

评分

参与人数 10下载分 +25 金币 +16 收起 理由
ZM199510 + 2 老司机!双击666+关注.....
yys1990 + 2 老司机!双击666+关注.....
lqxok + 2 给愿意分享经验的人加分!
水中月亮 + 2 给愿意分享经验的人加分!
汇滴成海 + 5 + 5 给愿意分享经验的人加分!
wsm001 + 2 给愿意分享经验的人加分!
天意wx + 4 给愿意分享经验的人加分!
always668 + 5 精品文章
方迷觴 + 5 + 5 对您的敬仰如同黄河泛滥,一发不可收拾
ZHAOXIN999 + 2 给愿意分享经验的人加分!

查看全部评分

发表于 2018-10-25 13:01 | 显示全部楼层
这种问题确实没碰到过,如果有遇到可以试试

回复 支持 反对

使用道具 举报

发表于 2018-10-25 13:41 | 显示全部楼层
这种问题,真的一般真不考虑会刷ec的bios。看楼主的案例很让人长见识。

回复 支持 反对

使用道具 举报

发表于 2018-10-25 14:06 | 显示全部楼层
楼主发文辛苦,感谢楼主分享。。

回复 支持 反对

使用道具 举报

发表于 2018-10-25 14:39 | 显示全部楼层
查的真是仔细,估计大部分都放弃了,此精神值得加分

回复 支持 反对

使用道具 举报

发表于 2018-10-25 15:11 | 显示全部楼层
EC的14.15脚按字面上面理解应该是音量调节,链接到EC的,EC那边应该是GPIO,由BIOS配置的

点评

恩 我也是这么考虑的 不过 这个两个脚 怎么测量好坏 我用示波器也没测到波形 也可能我测的方式不对  详情 回复 发表于 2018-10-26 09:23
回复 支持 反对

使用道具 举报

发表于 2018-10-25 20:34 | 显示全部楼层
一体机的板子比笔记本的复杂                                                      。

回复 支持 反对

使用道具 举报

发表于 2018-10-26 07:11 | 显示全部楼层
这机器是有自带音量静音控制按键触摸调节的,是否人误为把内制的声音功放制0音量或静音状态了呢?

点评

这个机器可以单独调节内置喇叭 不控制耳机吗 下次碰到 我调调试试  详情 回复 发表于 2018-10-26 09:18
回复 支持 反对

使用道具 举报

发表于 2018-10-26 08:14 | 显示全部楼层
感谢楼主分享经验,声音的问题出的不太多,大家都是修供电的几率比较高

回复 支持 反对

使用道具 举报

发表于 2018-10-26 08:15 | 显示全部楼层
感谢楼主分享经验,我个人修没声音的故障不多,学习了

回复 支持 反对

使用道具 举报

发表于 2018-10-26 08:47 | 显示全部楼层
ecbios会导致扬声器无声!真是第一次见!受教了!谢谢楼主分享!不过会不会与系统里设置了音量参数有关系哪?

点评

驱动重新装了 音量控制面板也调了  详情 回复 发表于 2018-10-26 09:20
回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-10-26 09:18 | 显示全部楼层
谢鸿 发表于 2018-10-26 07:11
这机器是有自带音量静音控制按键触摸调节的,是否人误为把内制的声音功放制0音量或静音状态了呢?

这个机器可以单独调节内置喇叭  不控制耳机吗    下次碰到 我调调试试

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-10-26 09:20 | 显示全部楼层
yys1990 发表于 2018-10-26 08:47
ecbios会导致扬声器无声!真是第一次见!受教了!谢谢楼主分享!不过会不会与系统里设置了音量参数有关系哪 ...

驱动重新装了  音量控制面板也调了   

回复 支持 反对

使用道具 举报

 楼主| 发表于 2018-10-26 09:23 | 显示全部楼层
always668 发表于 2018-10-25 15:11
EC的14.15脚按字面上面理解应该是音量调节,链接到EC的,EC那边应该是GPIO,由BIOS配置的

恩 我也是这么考虑的    不过 这个两个脚 怎么测量好坏   我用示波器也没测到波形    也可能我测的方式不对   

回复 支持 反对

使用道具 举报

发表于 2018-10-26 09:25 | 显示全部楼层
声音觉得吧是一个难题,很多都是外放没有声音耳机有,换芯片都不行,楼主查的这么仔细,辛苦了谢谢分享

回复 支持 反对

使用道具 举报

发表于 2018-10-26 14:49 | 显示全部楼层
碰到个短路烧HDMI转换芯片,功放声卡芯片的最后也是耳机有声音,外置没声音还好客户也接受了。要是早点看到你的帖子说不定就好了

回复 支持 反对

使用道具 举报

发表于 2018-10-28 14:39 | 显示全部楼层
EC的14.15脚按字面上面理解应该是音量调节,链接到EC的,EC那边应该是GPIO,由BIOS配置的

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长提醒 上一条 /1 下一条